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Welcome

Welcome to the ITSO, the birthplace of some of the world’s most widely read books—IBM 
Redbooks publications!

Really, how many other books can claim over half a million downloads per month?

This short Guide will give you the tools you need to write a book. The word processor you will 
use is Adobe FrameMaker. It is an easy-to-use, uncomplicated, and efficient tool. This Guide 
explains and demonstrates the basic elements you will use and ignores the more esoteric and 
complex functions that all modern word processors offer. If you need more than what is 
discussed here, see your editor or your project leader.

You are encouraged to resist the temptation to try to produce a literary masterpiece. Produce 
a technically useful masterpiece instead. To that end, a few instructions about technical 
documentation, Redbooks standards, and some writing tips are appended.

Your editors are here to assist you with the following:

� The use of proper English

� Simplifying unnecessarily complex or hard-to-understand material by rewriting or 
restructuring

� Ensuring that graphics are of good quality and complementary to the text (that is, useful)

� Problems with FrameMaker

� The importation of material from non-FrameMaker sources—Word, PDFs, spreadsheets, 
and others

� Where to find fine food

The ITSO also provides a collection of instructional videos that teach the material contained 
in this Guide. Use them to learn about a specific topic or when you need a refresher during 
your residency. You can find the videos at:

http://w3.itso.ibm.com/itsoapps/Redbooks.nsf/pages/w3fmlessons?Open
http://www.redbooks.ibm.com/redbooks.nsf/pages/fmlessons?Open

Now let us take a brief look at the book development process.
© Copyright IBM Corp. 2003. All rights reserved. v



Figure 1   The book development phases

1. Funders (product owners), ITSO managers, and Project Leaders (PLs) identify the need 
for a book and define its specific purpose. They publicize the project as a residency and 
use various channels to find qualified technical experts from all geographies. Obviously, 
they found you!

2. After you arrive at an ITSO center, your first day is spent in orientation sessions with the 
PL. The next day you receive instruction in book writing guidelines, corporate and ITSO 
standards, and in the basics of FrameMaker.

3. You and your team then do the necessary lab work, hold discussions with developers, run 
experiments, and document results.

4. You then write your assigned chapter. Editors review your first few pages and help you as 
needed.

5. After your team finishes its work, your PL completes the development phase by making 
necessary corrections and refinements, such as ensuring consistency across chapters.

6. The PL gets the required technical approvals and, if third-party Intellectual Property (IP) is 
used in the book, makes sure that legal approval is obtained.

7. If appropriate, the PL publishes the draft to the web.
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Note: Phases 3 and 4, of course, can be parallel processes throughout a residency.
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8. The PL makes sure that the book meets all requirements for final edit.

9. An editor now performs his/her magic on the book.

10.If technical reviewers have requested more changes, or the editor has suggested some 
restructuring or such, then the PL or the editor now makes the final updates.

11.The editor prepares the book for publication.

You now get to enjoy seeing your name on the cover of a bestseller!

Important: Legal approval does not have to be complete for final edit to begin.
 Welcome vii
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Chapter 1. Working with text in FrameMaker

This chapter covers the following topics:

� A few quick tips

� Using the paragraph catalog
Creating text and lists

� Using the character catalog
Highlighting

� Creating cross-references

� Creating and using variables

� Indexing

� FrameMaker shortcuts

1
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1.1  A few quick tips

To select a word, click it twice.

To select a paragraph, click it three times.

To select a string of characters, swipe your cursor across it. (Be careful not to include the 
end-of-paragraph tag in your selection.)

FrameMaker is set to allow only one space. If you need more adjacent spaces (when you 
format code, for example), press Ctrl+space.

When you press Enter, you get a new paragraph. To get a new line within the same 
paragraph, use Shift+Enter.

If you make a mistake, click Edit → Undo. There is more than one level of Undo.

1.2  Catalogs

The various text elements that make up a document are called paragraphs in FrameMaker. 
Whether plain text, headings, list items, or figure captions—they are all paragraphs.

FrameMaker provides a catalog of paragraph definitions (tags). You need only to select a 
paragraph in your document and click the appropriate tag in the catalog to change the 
paragraph to the desired format. 

FrameMaker also provides a catalog of character definitions. These are used for highlighting, 
that is, for changing the selected text from plain text to some other font or style or both, as 
appropriate.

Figure 1-1 shows the respective catalog buttons, which are located in the upper right corner 
of the window.

Figure 1-1   Where to find the catalogs

You can also view the catalogs by clicking Format → Paragraphs or Format → Characters. 
Using the buttons keeps the catalogs on the panel, making them more readily accessible.

1.3  The paragraph catalog

Your current paragraph type—that is, the paragraph type that corresponds to the location of 
your cursor—is always displayed at the bottom left and in the pull-down window at the top of 
the document window.

The Paragraph Catalog

The Character Catalog
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1.3.1  Paragraph text - Body tags

These tags define ordinary pieces of text, such as this paragraph. The Body1 
through Body3 tags are used to align paragraphs in a list. Each Body tag level 
corresponds to the List tag level in use.

1.3.2  Example text - code, commands, and web addresses

Use the BodyExample tag for code, command statements, web addresses, 
and message text. When using the bulleted or numbered list formats, use 
the BodyExample level that corresponds to the level of the list.

For larger bodies of nonproportional text, mainly sample scripts that might 
need to be referenced, see 2.5, “Inserting an example” on page 27.

1.3.3  Headings

These tags define your heading levels.

Head 0 is for chapter titles.

Head 1 is only used for the first level 2 heading of a chapter. It moves the 
heading to the next page after the chapter title page. A chapter should have at 

least one Head 1 and one Head 2 tag.

The others are self-explanatory. Head 4 and Head 5 are not numbered and do not appear in 
the TOC.

To create a new heading, simply press Enter for a new paragraph, type the text, and select 
the desired tag.

Headings for appendixes
These are the tags for appendix headings. Note that they do not create 
numbered headings. (Do not use the yHeadAppendixNumbered tags in 
books where you have already established the unnumbered appendix 
heading format. These are used for special situations only.)

Headings for unnumbered book parts
These are the heading tags for sections of your book that are not 
numbered, such as the Preface, Bibliography, and so on. They are not for 
use in regular chapters and appendixes.

1.3.4  The bulleted (unordered) list

These are the tags for creating bulleted lists, either with normal spacing 
between lines or with the spacing reduced (compact).

Use these tags whenever the order (sequence) is irrelevant.
Chapter 1. Working with text in FrameMaker 3



The following is a bulleted list containing all three levels (also called a nested list):

� NetBIOS (ListBulleted 1)

� TCP/IP 

When you press Enter, you get another paragraph of the same type (another level 1 
bulleted item). Select Body1 to change it to text of indent level 1.

Type your 2nd level bullet text and select ListBulleted 2.

– This is a 2nd level bulleted list item.

– Another.

• Pressing Enter and then selecting ListBulleted 3 gives you this.

• And again. On the next 3rd level item, simply click ListBulleted 1 to get back to the 
1st level.

� IPX

� SNA

To end a list, press Enter to create a new paragraph and apply Body0.

1.3.5  The numbered (ordered) list

These are the tags for creating numbered lists, either with normal 
spacing between lines or with the spacing reduced (compact).

Use numbering only when the order of the list items has significance, 
as for a sequence of steps.

The following is a numbered list containing all three levels:

1. NetBIOS (ListNumber 1)

2. TCP/IP (ListNumber 1next)

When you press Enter, you get another paragraph of the same type (another numbered 
item. Select Body1 to change it to text of indent level 1.

Pressing Enter again gives you more of the same. If you want to start a 2nd level 
numbered list, simply select ListNumber 2.

a. This is a 2nd level numbered list item.

b. Press Enter to continue the list.

i. Pressing Enter and then selecting ListNumber3compact gives you this.
ii. And again. On the next 3rd level item, simply click ListNumber 1next to continue 

the 1st level list.

3. IPX

4. SNA

To end a list, press Enter to create a new paragraph and select Body0.

If you already have a number of items typed and want to convert them into a numbered list, do 
this:
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1. Select the first item and click ListNumber 1.

2. Select all other items and click ListNumber 1next.

Do the same with nested items.

1.3.6  The definition list

These are the tags for creating definition lists. 

A definition list is composed of two elements: the definition term and the definition 
description.

To build your definition list, do this:

1. Click View → Rulers.

2. Click Graphics → Snap.

3. Type the term to be defined.

4. Press the Tab key.

5. Type the definition description.

6. Press Enter and repeat steps 3 through 5 for as many items as you are defining.

7. Select the entire block just created and click ListDefinition 1.

8. A little arrow appears on the ruler:

Move it with the mouse to where you want the text to start. Move the triangle to the same 
position for the second and subsequent lines. Make sure that Graphics → Snap is on 
when you do this.

The last step in the creation of a definition list is to highlight the definition terms by making 
them bold, so the final list might look something like this:

Red Delicious This is a scrumptious red apple grown in the Hudson Valley region.

Ida Red More than 50 years ago, horticulturists at the Idaho Agricultural Experiment 
Station took two popular apple varieties, Jonathan and Wagener, and 
crossed them. The result was the Ida Red apple, introduced in 1942, and 
named in tribute to the efforts of the researchers and for the variety's bright 
red color. 

Apples of New York State
If there is an unusually long item, use a line break (Shift+Enter) to avoid 
having the text compressed into a narrow column.

1.3.7  The special purpose list

The bulleted list is not always the appropriate list format. In some problem determination 
guides, for instance, extensive lists of possible problems and suggested actions are provided. 
These are not in any particular sequence, as in the case of installation steps, and so 
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numbered lists are also not the answer. The ability is needed to check off actions that have 
been taken, tasks that have been completed, and such, by people doing the troubleshooting.

To meet this need, the Checklist format is provided. 

 This is the 1st level of a Checklist, ListCheckBox1.

 This is the 2nd level of a Checklist, ListCheckBox2.

 This is the 3rd level of a Checklist, ListCheckBox3.

1.4  The character catalog

Use this catalog to apply highlighting to your text.

Figure 1-2   The character catalog

Default ¶ Font Use this tag to remove any of the highlight tags that you apply from this 
catalog and to return the text to the default format, which typically is Body0.

Bold Use this tag for actions selected from a menu, such as Format → 
Document → Text Options. 

Citation Use this tag to italicize the title of publications. Select the text and click 
Citation. The title of this booklet would look like this: Framemaker and 
Writing Guidelines for Residents, SG24-xxxx. Note that the number is not in 
italics.

Commands Use this tag for lowercase (that is, not VM or MVS) commands, such as UNIX 
commands like make. Select the command and click Commands, as was 
done here with “make”. This is a font change, so if you need to return “make” 
to “make”, use Default ¶ Font. See 6.4, “Highlighting” on page 75 for a more 
detailed discussion of command highlighting.

Emphasis Use this tag to emphasize (highlight) a word or phrase. To change your 
selection back to normal font, use Default ¶ Font.
You can also use “double quotes” to highlight text.

Note: Use this tag for inline commands, not for command statements that 
are on separate lines.

This is a portion of the catalog of 
font definitions. The ones you will 
most likely need for your book are 
now discussed.
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Example Use this font to change a word or phrase within a paragraph of normal text to 
nonproportional font. (For entire paragraphs, use BodyExample0.) To change 
your selection back to normal font, use Default ¶ Font.

Italic Use this tag for variables in code specifications, as in ABC.123.names. 

To make text bold, select it and click Bold. It is probably more convenient to open the 
QuickAccess Bar (View → QuickAccess Bar) and use the B button. To un-bold, use P or 
click B again. For Italic, press I. Or use the keyboard: Ctrl+b or Ctrl+i.

1.5  Establishing cross-references (x-refs)

To cross-reference a section of your document, or a figure, table, or example, click Special → 
Cross-Reference. You will then see the dialog box shown in Figure 1-3.

Figure 1-3   The cross-reference menu

Do the following:

1. In the Document pull-down, choose the file (chapter) where the referenced item is. That 
file must be open. (If it is in use, you cannot open it, so you cannot establish the 
cross-reference. Suggestion: ask your colleague to close his/her file for a few minutes.)

2. Make sure Source Type is set to Paragraphs. This tells FrameMaker that you will reference 
a known entity, that is, a defined paragraph type. (You can also define your own reference 
spots; see “Spot x-refs” on page 8.)

3. The Paragraph Tags list box now displays the paragraph catalog. Choose the paragraph 
type by clicking it.

Note: Do not use the {bracketed} tags of the character catalog.

Suggestion: Keep the QuickAccess Bar on your window. It offers additional text 
manipulation functions, such as Cut, Copy, and Paste. 
If you press this button:   the bar will be positioned vertically. You can then drag it to 
whatever spot is best for you.
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4. In the Paragraphs list box, choose the specific item you want to reference.

5. In the Format pull-down menu, choose the reference format FrameMaker will use in your 
text. 

6. Click Insert.

This is the Format pull-down.

For numbered headings, use Num Head Page.

For unnumbered headings—Head 4, Head 5, and in special 
chapters such as the Preface—use Head Page.

For a chapter, use Chapter. For an Appendix, use Appendix.

Use Example Nopage, Figure Nopage, Table Nopage, and List 
Nopage for those items. Use Example, Figure, Table, and List if 
the item is more than a page or two removed from the 
reference to it.

For another method of inserting a cross-reference, see Chapter 2, “The Toolkit and the QAM” 
on page 17.

Typical references will look like this: 

� 1.3, “The paragraph catalog” on page 2.

� Figure 1-1 on page 2.

� Example 2-1 on page 27.

To reference an item in a numbered list, select the proper tag (ListNumber 1, ListNumber 
1next, and so on), select List, select the desired list item, and click Insert. You will get, for 
example, 3 on page 5. If you add an appropriate prefix to this, you might have: Refer to Step 3 
on page 5.

Spot x-refs
If you have pages of normal text with no specific paragraph tags to refer to, then create your 
own spot marker, as follows:

1. Position the cursor at the point you want to reference.

2. Go to Special → Marker → Cross-Ref, enter a name by which you will know this spot, 
and click New Marker.

3. Go to where you want to enter the cross-reference.

4. In the Document pull-down (Figure 1-3 on page 7), choose the file (chapter) where the 
referenced item is. That file must be open. (If it is in use, you cannot open it, so you cannot 
establish the cross-reference. Suggestion: ask your colleague to close his/her file for a few 
minutes.)

5. Set Source Type to Cross-Reference Markers. 

6. Find the spot name you created in the Cross-Refence Markers list box. Choose it by 
clicking it.

7. In the Format pull-down menu, choose Spot. 

8. Click Insert. Only the page number of the spot is inserted in the text.

Tip: Clicking Go to Source gets you to the cross-referenced location. 
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9. Prefix the page number with enough text to identify the spot. For example: See “Your 
project ...” on page 9.

To get back to the cross-reference menu to make a change to any x-reference, double-click 
the reference in the text.

See 2.2.11, “Insert Xref To Next Caption” on page 21 and related topics for a quick and easy 
way to insert cross-references after you have become familiar with this function.

1.6  Using and managing variables

Variables (also called symbolic names) are used to help ensure correct spelling, consistency 
across chapters, and to reduce typing chores.

Your project leader might have created a list of variables representing terms such as product 
names, book titles, and frequently used technical expressions that are related to the topic of 
the book you are developing. Check with him/her before creating your own variables.

Accessing and inserting a variable
There are two ways to access and insert a variable:

� Click Special → Variable, select the variable you want, then click Insert.

� Press Ctrl + 0 (zero) on the keyboard. You will see a blue field in the lower left corner of 
your panel. Start typing the name of your variable until you see the one you want (that is, 
until enough letters have been entered to make the string unique), then press Enter to 
insert it into your document.

Note: Method 2 is much quicker (if you know the name of the variable).

Creating a new variable
If you find it advisable to add variables to the list provided with your file, do the following:

Click Special → Variable → Create Variable. The following window opens:

1.In the Name field, type in a short name that you will 
easily recognize (for books, the last four numbers are 
a good choice).

2.In the Definition field, type the full expression into 
which the variable will expand.

3.Insert Character Formats as needed.

4.Click Add, then Done twice.

The definition for a Redbooks publication, for example, looks like this:

<Citation>What I Did Last Summer<Default ¶ Font>, SG24-1234
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Changing a variable definition
Click Special → Variable → Edit Definition. The current definition of the variable appears in 
the Definition field. Simply type your changes, then Change → Done.

Managing variables
The proper management of variables is as important as their intelligent creation. When you 
create a variable, it is available to your file only. Because a book is developed by several 
writers, all working simultaneously on their respective chapters, it is entirely possible that 
separate variable names are created for the same expression (book title, product name, and 
so on). This, of course, will cause obvious problems.

To avoid this situation, the following steps should always be taken immediately after creating a 
variable (your project leader might ask you to leave this task to him/herself):

1. Open the vars file. This file is not part of the book but exists solely as a common repository 
for variables.

2. Go to File → Import → Formats. The following menu appears.

3.. Now click Deselect All and then select 
the Variable Definitions check box.

4. Change “Import from Document:” from 
Current (which is the vars file) to your 
chapter file.

5. The menu should now look as follows:
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6. Click Import.

7. Close the vars file as soon as this is 
done to make it available to your colleagues 
for the same purpose.

8. Notify your colleagues about the 
variables you have created.

Note1: At the end of the day, your project 
leader imports the variables from the vars 
file into all book files.

Note2: The same steps should be 
performed whenever you change an 
existing variable.

You may optionally enter the variable into the table under “1. Project Variables” in the vars file 
to make the list of variables easier to see and manage. Do the following:

1. In the Variable Name column, type the name of your variable.

2. In the Value column, insert your variable as explained in “Accessing and inserting a 
variable” on page 9.

3. If you think it might be helpful, enter a description of your variable in the Description, 
Comments column.

1.7  Indexing

Your project leader might or might not ask you to mark entries for the index as you write. If 
asked to do so, here’s how:

1. Click Special → Marker. Make sure the Marker Type is Index.

2. Select the word or expression you want to appear as a first-level entry in the index. You will 
see your selection entered in the text area of the Marker window. 

3. Click New Marker. That’s it. 

To create another entry within the same marker, type a semi-colon (;) after your first entry and 
then type your next entry. 

To change an existing entry, open the Marker window, then swipe across the marker symbol 
in the text, T. The entry appears in the text area. Change it as needed and click Edit Marker.

Tip: Use lowercase on index entries, unless a term is a proper noun such as a product 
name. For proper nouns, use the appropriate capitalization, either mixed case or all 
uppercase.

Recommendation: Mark first-level entries only—let your project leader design the index 
structure later. This way, you, the author, decide the basic content of the index. This 
method also greatly simplifies the final task for the project leader.
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1.8  Bringing text from another source into FrameMaker

You can copy text from other sources and paste it into FrameMaker.

1. For Word and WordPro, highlight your text and select Edit → Copy or press Ctrl +c.

2. In FrameMaker, place the cursor in the document where you want to paste the text. 

3. Select Edit → Paste Special → Rich Text Format and click OK. 

4. Reformat the text, as necessary, using the FrameMaker tags.

From Lotus Notes, a simple Copy+Paste will do.

1.8.1  Resolving the Unavailable fonts message

It is possible that after you import and format your text in FrameMaker, you get the 
Unavailable Fonts message the next time you open the file. 

Follow these steps:

1. In FrameMaker, open the file. 

2. From the Toolkit in the menu bar, select RXFM → PDF_build_error_tools → 
Find-Non-Standard-Fonts.rex. 

3. On the window that opens, click OK. Let the tool run. 

4. When the tool has finished, a window opens that tells you whether you have nonstandard 
fonts. 

– If the tool does not recognize that you have nonstandard fonts, ask your project leader 
or editor to fix this for you.

– If the tool recognizes that you have nonstandard fonts, click OK on the message 
window. 

Figure 1-4   Nonstandard font message

Important: If you do not use Paste Special, FrameMaker places the text into a frame. 
Simply undo the action (Ctrl+z) and follow steps 1-4.
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A window opens that lists where the nonstandard fonts are by page number (see 
Figure 1-5). Click the link to the page and reapply the paragraph tag and the Default 
character tag. 

Figure 1-5   Message window that identifies and links you to the font error

1.9  Spelling Checker

Click Edit → Spelling Checker and you get the menu shown in Figure 1-6. You are familiar 
with this function, but it might be worthwhile to point out a few things.

Figure 1-6   The Spelling Checker window

� Change the selection from Book to Document

� Click Options to familiarize yourself with the selections for Find and Ignore.

� When the Checker stops at a valid term that is not in its dictionary, click either:

– Allow in Document, which adds the term to this document’s dictionary, and it will not 
stop at that term again.

Note: If you do not see the highlighted text, look for your cursor on the page. It might 
be that you have an unavailable font appearing in rather small text in a blank area. 
Simply press Backspace to delete that font.
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– Learn, which adds the term to a permanent personal dictionary, and it will also not stop 
there again.

In either case, if you change your mind (maybe you did not mean to say Allow or Learn), 
select the term and click Unlearn; this removes the term from either dictionary.

� When the Checker stops at a word that is obviously misshelled, make sure you check the 
suggested Correction before you press Correct; see Figure 1-7. If you do not see the 
correctly spelled word in the Correction box or in the other suggestions, as in this case, 
you can type it into that box and click Correct; or you can just click in the text itself and 
correct it yourself.

Figure 1-7   Notice the Correction suggestion

Spelling Checker is a useful tool. It cannot, of course, catch words that are spelled correctly 
but used incorrectly—there, their, and they’re; or it’s and its, which are so often confused. 
Such cases are left to your human editor.

Important: You can have the Checker ignore all paragraphs with the BodyExample tag; 
see 2.2.25, “Spell Check Off” on page 25.
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1.10  FrameMaker shortcuts

Table 1-1 offers a list of FrameMaker shortcuts.

Table 1-1   FrameMaker shortcuts

Shortcut Action

Ctrl-L Refresh Screen

Ctrl-Z Undo

Ctrl-X Cut

Ctrl-C Copy

Ctrl-V Paste

Ctrl-0 (zero) Variable bar will appear at bottom left of your 
window. Select variable and press Enter, and 
the variable will enter your document at the 
cursor position.

Ctrl+q Shift-q Em-dash (—)

Ctrl+q Shift-p En-dash (–)

Ctrl-Space Non-breaking space

Double click Select a word

Triple click Select a paragraph

Ctrl-m Select Paragraph Designer 

Ctrl-P Print

Ctrl-S Save

Ctrl-G Go to Page - insert page #, & press Go

Ctrl-D Bring up Character Designer

Ctrl-F Bring up Find/Change 

Ctrl-H Remove last typed word

Ctrl-t Select Table Designer 

Esc Tab To add <tab> in cell of a table

Esc t w Columns so no paragraph in cell wraps

Ctrl-O Open file

Ctrl-Space Add extra space (force more than one space)

Start a new sentence One space after period 

Start a new paragraph Press Enter

Insert Tab in Table Cell Press Esc-Tab, pull-down Tab marker for Tab 
placement
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Chapter 2. The Toolkit and the QAM

The Toolkit was created by the ITSO to provide residents, project leaders, and editors with a 
set of tools designed specifically for IBM Redbooks publications and Redpapers. This chapter 
introduces you to many of the functions offered by the Toolkit.
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2.1  The Toolkit

The Toolkit menu (Figure 2-1) provides the paths to many helpful functions. 

Figure 2-1   Overview of the Toolkit menu

The ITSO has supplied a number of REXX scripts to make the creation of a book easier, more 
efficient, and more trouble free. A subset of the many tools available is offered here.

These REXX scripts are great time savers. Use them. 

2.2  Your Quick Access Menu 

First, let us look at the default Quick Access Menu (QAM), which offers most of the REXX 
functions needed for writing a book. Later we show how to customize it.

Select Toolkit → Quick Access Menu. 

Figure 2-2 on page 19 shows a sample QAM for a residency. At the top of this window are the 
following buttons:

>[F] allows you to increase the font size of the options shown in the window.

Preferences lets you define how you want the window to display within FrameMaker.

Home displays your custom menu.

Help provides a brief explanation of all buttons.

[f]< allows you to decrease the font size of the options shown in the window.

With Customize you select the tools to display on your Home menu. 

Show all tools displays, as buttons, all the RXFM tools. 
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Figure 2-2   A basic QAM

A brief explanation of these functions follows. Greater details are provided in subsequent 
sections, as appropriate. 

2.2.1  Insert figure frames

The next two functions insert the proper frame for various contents into your file. 

Insert Figure Box For Graphics
This inserts a solid frame into your file. It is used mostly for artwork. See Chapter 3, 
“Importing graphics” on page 31 for examples.

Insert Figure Box For Text Only
This inserts a table cell into your file. It is used for text-only panel captures. See 4.6.1, 
“Copying and pasting the text” on page 58 for details.

2.2.2  Insert Anchored Boxes

Inserts various Anchored Frame boxes without captions—inline, at the beginning of a 
paragraph, in the margin, or in the chapter head.

After you click this choice, a menu appears on which you choose the Anchored Frame you 
want. See 4.4, “Inline graphics” on page 55 for details.

2.2.3  Insert a Shaded Box

You may want to provide a reminder, tip, or note to the reader. See 2.4, “Inserting a Shaded 
Box” on page 26 for a detailed discussion.
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2.2.4  Insert Example

For code samples and large bodies of nonproportional text, such as sample scripts, use the 
Example template (do not use for messages or command sequences). See 2.5, “Inserting an 
example” on page 27 for a detailed discussion.

2.2.5  Insert Table 

This inserts a table that you can then modify with the Table menu to meet your requirements. 
Do not use the Insert Table function of the Table menu. See Chapter 5, “Tables” on page 65 
for details.

2.2.6  Insert Arrow

Inserts the arrow variable symbol → at the cursor position. 

2.2.7  Insert Menu Command

If you’re directing the reader to make consecutive selections from a menu, these need to be 
bolded with an arrow between them. Highlight the two items in the text and then apply this 
function. You will get this: Item1 Item2, with the blank highlighted. Then click Insert Arrow 
before typing anything else.

If you highlight nothing, this function inserts a template, ? → ? → ?. Replace the question 
marks with your menu selections. 

2.2.8  Insert Redbooks Titles

This function helps you find the full title and number of Redbooks and Redpapers, creates a 
variable for them, and inserts them into your file. A window with a detailed description opens 
when you click it.

2.2.9  Insert Special Characters

This opens the submenu shown in Figure 2-3, which offers time-saving shortcuts to many 
symbols and a few useful functions. Clicking ShowReverseVideo, for example, opens a 
menu that enables you to insert reverse color numbers, for instance  or 3.
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Figure 2-3   The Special Characters submenu

2.2.10  Insert Xref

There are a number of ways to insert a cross-reference. Choosing this one opens the 
instruction box shown in Figure 2-4. Here is another way of describing the process:

1. Position the cursor where you want the Xref to be inserted.
2. Select Insert Xref from the QAM.
3. Move the cursor to the item you want to cross-reference.
4. Click Ok.

Figure 2-4   The Insert Xref instructions

2.2.11  Insert Xref To Next Caption

This is a quicker way for inserting a cross-reference to figures, tables, and examples. Clicking 
it here gives us: Figure 2-5 on page 23. Double-clicking this opens the Cross-Reference 
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menu, where you can then simply select the item you really want, and then click Replace. For 
a detailed discussion of the cross-referencing process, see 1.5, “Establishing 
cross-references (x-refs)” on page 7.

2.2.12  Insert Xref To Prev Caption

This is the reverse of Insert Xref To Next Caption.

2.2.13  Insert Xref To Heading

Clicking this here gives us: 2.2.14, “Insert Xref To Chapter” on page 22. Then follow the 
instructions that pop up.

2.2.14  Insert Xref To Chapter

Clicking this here gives us: Chapter 2, “The Toolkit and the QAM” on page 17. Then follow the 
instructions that pop up.

2.2.15  Insert Xref To Footnote

See 5.5.1, “Creating table footnotes” on page 68.

2.2.16  Insert Author Comment Box and Insert Author Comment

There may be times when you need to insert reminders to yourself or comments to your 
project leader, the developer, or a reviewer. Click Insert Author Comment Box. The following 
example shows how this option appears on the page—in red.

You can also insert a comment directly into a paragraph by clicking Insert Author Comment, 
which gives you this <<  >>. Type your comment between the symbols.

Prior to publishing, such boxes and in-line comments will be removed—or “turned off” via the 
Conditional setting if information is to be passed on to the next team that will update the 
document.

2.2.17  Paragraph Object Shift Right

Moves or indents paragraphs or objects you have selected to the right.

Example: To line up a graphic with a level 1 list item, move the cursor into the caption and 
click Paragraph Object Shift Right. Figure 2-5 on page 23 shows the result.

Author Comment: 
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Figure 2-5   Object and caption shifted to the right

2.2.18  Paragraph Object Shift Left

Moves or indents paragraphs or objects you have selected to the left.

This is the opposite of the Shift Right process. Use this function to change a column-wide box 
to a page-wide box.

2.2.19  Toggle Table To Column Page

Use this tool to resize a table that was copied from an MS Word document or an MS Excel 
spreadsheet. It will also toggle a column-wide table to a page-wide table proportionally, and 
vice versa. See Chapter 5, “Tables” on page 65 for an example.

2.2.20  Outline

Clicking Outline offers the dialog window shown in Figure 2-6 on page 24.

Column-wide versus page-wide: Column-wide is the standard size for all templates in 
the Toolkit. It has the same width as this note box. Page-wide is the exception. It is 
intended for items that have more detail and require the entire page width.
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Figure 2-6   Partial outline of this chapter

In the Chapter 2 file, FrameMaker paragraph tags Head 0 through Head 5 display in the 
dialog window. 

The Outline tool offers the following:

� Dialog list box actions

– Expand or Collapse one heading level or all levels using (++) or (- -) 
– Print the dialog's contents to the FrameMaker console
– Synchronize the FrameMaker Cursor position and the dialog list box item

� FrameMaker single line actions

– Find a heading (dialog item) in the FrameMarker source file 
– Promote or Demote a single heading (dialog item) one level in the FrameMaker source 

file

� FrameMaker heading tree actions

– "<<Pro<"(promote) or ">Dem>>"(demote) all headings in the FrameMaker source file, 
under the selected heading tree 

– Copy or Cut a FrameMaker source file heading tree to the clipboard 
– Paste the clipboard contents into the FrameMaker source file before the selected 

heading (Paste requires a previous Copy or Cut action.)

� Show only

This choice lets you select which levels, or which tags, you want displayed.

For a demonstration of this powerful tool (similar to a tool in Word), consult with your project 
leader.
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2.2.21  Make FigureFrame Solid or Hidden

This changes the border of frames and of graphics:

� A hidden border is changed to a solid border.

� A solid border is changed to a hidden border.

2.2.22  Align Graphic

When bringing a capture into a frame, you usually have to move the file to the left and top and 
adjust the bottom. This function does it for you. Simply select the graphic (not the frame!) and 
click Align Graphic.

Clicking the P on the right border lets you select the width of the space around the graphic, as 
shown in Figure 2-7.

Figure 2-7   Specifying space around a graphic

2.2.23  Fix Wrapped Heading

When a Head4 or Head5 exceeds the length of the line, you get this:

This heading just goes on and on and on and on and on and then wraps because it reaches the end of the line
Click Fix Wrapped Heading, and all is well:

This heading just goes on and on and on and on and on and then wraps 
because it reaches the end of the line

2.2.24  Keep with next

Sets “Keep With: Next Pgf” for a selected paragraph. For example, if the introduction to a list 
is at the bottom of a page and the list then starts on the next page, use this function to glue 
the two together.

2.2.25  Spell Check Off

Select this function before you start the Spelling Checker (1.9, “Spelling Checker” on 
page 13). This tells the Checker to ignore all paragraphs with a BodyExample tag, such as 
code samples, websites, and so on.
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2.2.26  Fix Locked Text

When importing a Word document to FrameMaker, the imported text can have the locked bit 
turned on. This function unlocks the text.

2.3  Customizing your QAM

If you want to shorten the QAM so that it takes up less space on your desktop, or you want to 
add RXFM functions that are not in the default QAM, click Customize. The tools selection 
menu opens. Choose the tools you want to add or deselect the ones you do not need and 
click OK. 

2.3.1  An abundance of tools

There are many more tools in this rich toolbox. If you are curious, click Show all Tools in the 
QAM. Figure 2-8 shows the menu that appears. 

Figure 2-8   The All Tools menu

Now click any of these choices, perhaps Author tools 2, and see whether you need any of 
the functions offered.

2.4  Inserting a Shaded Box

You may have additional information that you want to provide as a reminder, tip, or note to the 
reader. In the QAM, click Insert Shaded Box. The following example shows how one of these 
boxes appears on the page. You simply type your information right after the colon (:).

Note: 
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The tool knows when you are in a list and will choose the appropriate indent level. Example:

� First-level Note. 

You can change the label of the box if some other text is more appropriate. For example, text 
related to the technical content of the Note is often more informative. Also, note that some 
labels are reserved for specific purposes: Attention is used “if an action can cause physical 
harm to you such as crushing your fingers or electrocuting you”—not a likely hazard for book 
material.

2.5  Inserting an example

For code samples and large bodies of nonproportional text, such as sample scripts, use the 
Example template (do not use it for messages, command sequences, or written content 
examples such as scenarios). 

In the QAM, click Insert Example. The template shown in Example 2-1 is placed into your 
file.

Example 2-1   A column-wide example

Now click at the start of the enclosed space and paste your script here. The space expands 
as needed.

If your example is column-wide, use BodyExample0 or BodyExample1 to align the text.

If your example is page-wide, use zBodyExample0.

Example 2-2 shows how an Example may appear on the page.

Example 2-2   Sample REPRO statements for copying bin numbers 

REPRO INFILE(SOURCE) OUTFILE(OUTS1)         -
       FROMKEY(C'RUVLT1    CARTS   V10001') -
         TOKEY(C'RUVLT1    CARTS   V10500')
REPRO INFILE(SOURCE) OUTFILE(OUTS1)         -
       FROMKEY(C'SUVLT1    CARTS   V10001') -
         TOKEY(C'SUVLT1    CARTS   V10500') 

Note: The levels maintain proper left alignment of the text within the list.

Guidelines for Notes: 

� Avoid placing two Note boxes consecutively. Make a list of Notes in one box.

� Avoid placing more than two Note boxes on a page. 

Important: If the Example space is the last “line” of your file and you want to add more 
paragraphs of normal text, use the arrow keys on the keyboard to get to the end of the 
second line and press Enter.
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2.6  Marking text with change bars

It can be useful or even essential to mark new additions or changes to your document. This is 
helpful to your colleagues and project leader to see what changes have occurred over the 
development of the document, such as from the first draft to the second draft and so on. It is 
also useful for marking changes in previously published books or papers that are being 
updated. Plus it helps to speed up the editing process, allowing the editor to edit only those 
places marked by a change bar instead of having to re-edit the entire book.

There are several options for activating the change bars in FrameMaker.

� If you are updating a chapter, use either of the following options from the menu bar. Both 
options mark any information that you add or change with a change bar.

– Select Toolkit → ChangeBars → Enable Auto ChangeBars. 

– Select Format → Document → Change Bars. In the Change Bar Properties panel, 
select the Automatic Change Bars box and click Set. 

To remove all the change bars in a file, do one of the following: 

– Select Toolkit → ChangeBars → Clear All ChangeBars.

– Select Format → Document → Change Bars. In the Change Bar Properties panel, 
select the Remove All Change Bars box, and click Set. To remove only specific bars, 
see the next bullet.

� To mark only specific pieces of text:

– Select the text and click Format → Style → Change Bar. This marks as many lines as 
you selected. To remove the change bar, repeat the process.

2.7  Hyperlink tool for web addresses

When referring readers to websites, use the Make URL Hot feature in Toolkit. This feature 
creates a hyperlink to the site. Follow these steps:

1. Write the web address on a separate line.

http://www.redbooks.ibm.com/

2. Apply the BodyExample format. In this case, we use BodyExample1.

http://www.redbooks.ibm.com/

3. Highlight the address, being careful not to extend past the end of the line.

4. Select Toolkit → Make URL Hot. The web address changes to the color blue. The text 
symbol that appears at the start of the address is the hypertext marker that is created by 
the Make URL Hot tool.

Note: You can also use the Change Bar Properties panel to modify the appearance 
of the change bars.

Note: To turn off the setting of change bars, select Toolkit → ChangeBars → 
Disable All ChangeBars. After setting this option, you still see all the change bars 
that were set up to the point of disabling the function.
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2.8  Chapter Heading Box

The Chapter Heading Boxes are the two boxes that appear at the beginning of the chapter, 
the shaded box that contains the chapter number and the placeholder box to the left of the 
chapter title. 

If you accidentally delete one or both boxes, you can reinsert them into the document as 
follows:

1. Place your cursor to the left of the chapter heading text.

2. In the QAM, click Insert Anchored Boxes → Chapter or Appendix file heading 
boxes → OK.

The tool will know whether it is a chapter or an appendix.
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Chapter 3. Importing graphics 

This chapter describes how to get graphics (that is, artwork, diagrams, and so forth) into your 
document.

First, create an addmat subfolder in your book directory for your Freelance, PowerPoint, and 
Visio graphics.

3

© Copyright IBM Corp. 2003. All rights reserved. 31



3.1  Using the QAM 

The first step in getting graphics into your document is to create an anchor frame for it. Click 
Toolkit → Quick Access Menu and then select Insert Figure Box For Graphics.

The desired anchor box and its caption are now in your document (Figure 3-1).

Figure 3-1   Type your caption here

3.2  From your graphics program into your document

First: 

1. Create your graphic in Freelance, PowerPoint, or Visio.

2. Use one file for multiple drawings. Ask your Project Leader how the directory is set up.

3. Select File → Save to save the source file in the addmat subfolder of your book directory 
(if there is no such subfolder, create it). Use a name that relates to the subject matter.

Note: Do not save your window captures in Freelance, PowerPoint, or Visio! See 
Chapter 4, “Panel and window captures” on page 43.

Important: Do not use gradient fills. These produce unpredictable results.
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Then place the graphic into FrameMaker as explained in the following sections.

Freelance
4. Open Freelance.

5. Find your graphic.

6. Use Page Sorter to display the thumbnail (whether a single graphic or part of a 
presentation), and click it. Don’t open it, just highlight it.

7. Click Edit → Copy, or press Ctrl+C.

8. In FrameMaker, select the frame, then select Edit → Paste (Ctrl+v).

Linking the object

To link the object into the FM file, select Edit → Paste Special (Ctrl+Shift+v), then click Paste 
Link → OK.

Tips for Freelance: 

� It does not matter whether the Freelance file is open or closed when linking it into the FM 
chapter.

� But it must be closed before double-clicking it in FM to make changes.

Visio
The process for Visio is exactly the same as for Freelance.

Tips for Visio: 

� If you are linking the object into the FM file, do not close the Visio file. Leave it open.
� As in Freelance, the file must be closed for the double-clicking to work. 

PowerPoint
In PowerPoint, click the Slide Object (thumbnail), not the graphic. Otherwise, the process is 
exactly the same as for Freelance.

Tips for PowerPoint: 

� Do not close the PowerPoint file after copying until you have linked it into the FM file (if you 
are linking it).

� There is no need to close it before double-clicking it for updating.

Important: If there is no need to keep the source and the book files in synch, then linking 
the object into the FrameMaker file is unnecessary and is not advised. Changes to the 
latter can always be effected by simply double-clicking the graphic. See 3.2.1, “Updating a 
graphic” on page 35.
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Resizing your graphic
The newly pasted graphic will rarely be the proper size, as shown in Figure 3-2.

Figure 3-2   After pasting in a graphic

Now do this:

1. Select the graphic by clicking anywhere inside it.

2. Drag it to the upper left corner.

3. With the graphic still selected, hold down the Shift key and drag the lower right handle 
(corner) until the graphic is large enough and consistent with others in your document.

4. If the anchor box does not allow sufficient enlargement of the graphic, select the bottom 
handle of the frame and drag it down. Then repeat step 3.

5. If the anchor box is too large after expanding the graphic, grab the bottom handle and 
push it up (as in this case).

Figure 3-3 on page 35 shows the result.
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Figure 3-3   Resized and repositioned graphic

A perfect fit
After you are happy with the dimensions of your graphic, there is no need to position it 
manually and to adjust the frame around it. Select the graphic (not the frame), then click Align 
Graphic in the QAM. Click the P to the right of Align Graphic to specify the desired white 
space around the graphic. See 2.2.22, “Align Graphic” on page 25.

3.2.1  Updating a graphic

To update the FM graphic, double-click it. This gets you either to a clipboard copy or, if the 
object was linked, to the source. Apply your changes. They are automatically reflected in the 
FM file.
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Important: In Freelance and Visio, make sure that the graphic source you want to update 
(if linked) is not already open. If it is, you will get no response to the double-click. In Power-
Point, it makes no difference.
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3.3  Inserting a frame for both text and graphics

In the QAM, select InsertFigureBoxForTextWithGraphics. This will give you a frame for a 
graphic plus an inside text box that you can then use to annotate the graphic. Resize the text 
box as necessary to suit your text and then place your image into the frame.

Figure 3-4 illustrates how to use this template.

Figure 3-4   Using the Box-For-Text-With-Graphics template

3.4  Insert a frame for text only

In the QAM, select Insert Figure Box For Text Only for 3270, 5250, green screens, and 
other text-based screens. In Redbooks and Redpapers, we display text-based versions of 
these screens and not window captures because the black background makes it difficult to 
read the text on a printed page. 

Follow these steps:

1. Access the panel that you want to copy. 

2. Select the panel text and copy it (press Ctrl+c, or select Edit → Copy, or use whatever 
method the application offers).

3. Back in FrameMaker, place your cursor in the text-only frame and paste the panel text into 
the template (press Ctrl+v or select Edit → Paste). 

Here is an example of how to use the box you get with this 
template.

First resize the text box to make room for the capture or artwork: 
Ctrl+click and move the inner dotted box.

Now insert the artwork, and adjust both areas as desired. You 
can, of course, move the text box to either side, or under the 
graphic.

This is the most effecient way for annotating a graphic.

To draw arrows and such, see 4.3.6, “Annotating your drawings 
and captures” on page 51.
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The box (actually, a table cell) automatically expands to hold the text. The BodyExample0 
format is applied, which maintains proper tab and column alignment. 

3.5  Of colors and clip art

FrameMaker does not handle Freelance pattern colors (gradients) very well. When printed, 
the result is often a balloon or some other unpredictable shape around the object.

You might, of course, want fancy gradient colors in your graphic, especially when it is also 
used for workshop presentations or such.

This section addresses these issues. Figure 3-5 shows which part of the color palette to use 
when creating a graphic with Freelance. 

Figure 3-5   Use only solid colors

Alignment of panel names: You might notice that after you paste your text into the 
template, your panel for the most part maintains proper alignment. However, the name at 
the top of the window does not. It shifts to the left instead of staying in the center. 

To correct this, place your cursor at the beginning of the line before the title. Then hold 
down the Ctrl key and press Spacebar the number of times necessary to move the title 
back to the center.

.PRZ file

Pattern color

goodnot good

 If you want to use color for your Freelance graphics (.prz files):
 Never use pattern color
 Use only solid color 

Solid color

Pattern color

.PRZ file

Pattern color
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Freelance clip art
If you insert Freelance clip art with pattern colors into your graphic, you need to change these 
to solid colors, as shown in Figure 3-6.

Figure 3-6   Changing clip art from Freelance graphics to solid colors

goodnot good
 If you want to use Clip Art from Freelance graphics (.prz files):

Change pattern color to solid color 

Clip Art graphics with pattern color
38 FrameMaker and Writing Guidelines for Residents



Use clip art from other sources
If you really want to have more sophisticated artwork (that is, clip art) in your picture, import it 
in a format other than .PRZ, that is, use artwork created with another tool (such as Paint Shop 
Pro) and saved as GIF, JPG, or BMP. 

In Figure 3-7, Freelance clip art with pattern colors is replaced by similar artwork in formats 
that work.

Figure 3-7   Replacing Freelance graphics with other formats

There is plenty of fine clip art on the web that is not copyright-protected. 

goodnot good

 If you want to use pattern color for your illustrations:
Use .JPG, .GIF, .BMP format graphics

.BMP,.JPG, .GIF file -only

.BMP,.JPG, .GIF file -only

Clip Art graphics with pattern 
color
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Text guidelines for graphics
Figure 3-8 illustrates some guidelines concerning text:

� Text should be centered in the object that contains it.

� Use the same font throughout, which should be sans serif (“without feet”).

� Text must not touch object borders.

� Do not use dark lettering on dark background.

� Connecting lines must not cross text.

Figure 3-8   Proper text design and placement
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Use of photographs in graphics
Figure 3-9 simply emphasizes that only the most current pictures should be used for servers 
or any other hardware. 

Figure 3-9   Correct pictures of servers
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Chapter 4. Panel and window captures

This chapter describes how to use the ITSO-recommended tools for taking panel and window 
captures, and offers hints and tips on what to do and what not to do.

First, create an Images subfolder in your book directory for all GIF files.

4

Note to residents: You will probably not need to become familiar with all the details in this 
chapter, such as “4.8, “Best practices for capturing” on page 61”. Your project leader knows 
which topics are required for a particular residency.
© Copyright IBM Corp. 2003. All rights reserved. 43



4.1  Introduction to capturing

A capture is a bitmap graphic (for example, GIF) of a whole or partial window or panel. 
Typically, a capture helps explain a procedure. 

The appropriate use of panel and window captures (let us just call them captures for brevity) 
is an essential part of quality technical documentation. Unfortunately, it is easy to produce 
captures of poor quality, and their effect can range from being simply distracting to the reader 
to a loss of confidence in the quality and accuracy of the technical material.

Here are the simple rules:

� Black panels are not acceptable. See 4.6, “Black panels” on page 56.

� The text on captures must be legible. It is not acceptable to show numerous fields and let 
the reader guess what their description (purpose) might be.

Important: Observe the following ITSO standards for captures. Your book may not be 
acceptable for publication if you ignore these standards.

After your residency is over, there is no way to recapture or redraw any unacceptable 
captures, and often the only solution might be to delete them and use words to describe 
the pertinent technical data. If such a graphic is crucial for understanding of the material 
(that is, if words are not sufficient), then the project leader and publishing team will be 
faced with a dilemma.
44 FrameMaker and Writing Guidelines for Residents



4.2  A quick guide

There is a lot of material in this chapter. You do not need to know all of it for most captures. 
Here is a quick guide that should meet most requirements, especially after you have 
familiarized yourself with the basic terminology and techniques. Go to the appropriate section 
to do that, as needed.

1. Open Paint Shop Pro (see 4.3, “Using Paint Shop Pro to capture panels and windows” on 
page 46 for details).

2. Click File → Import → Screen Capture → Setup.

3. Choose a type of capture and set an activation method. Do not use the right mouse click, 
use a function key.

4. Click File → Import → Screen Capture → Start. Alternatively, press Shift+c.

5. PSP minimizes and waits for you to do a capture.

6. Use the activation method you defined.

7. Specify GIF as the file format and save the file, with a logical name, in the addmat folder of 
your book directory (see 4.3.2, “Saving the capture” on page 47).

8. Insert an anchor frame with the Toolkit (see 4.3.3, “Inserting a capture into your document” 
on page 48).

9. Select the frame by clicking anywhere on the border, then click File → Import → File.

10.Navigate to the subdirectory where you saved your capture (Images\chapterx) and select 
the image, then select Import by Reference or Copy Into Document on the Import 
dialog menu and click Import.

11.Either select the dpi value from one of the radio buttons, or enter the value in the Custom 
field (use 120 as a start), and click Set.

The capture is now in the anchored frame.

12.Annotate the capture if desired (see 4.3.6, “Annotating your drawings and captures” on 
page 51).

Note: Other capture programs, such as SnagIt, can also be used.
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4.3  Using Paint Shop Pro to capture panels and windows

Paint Shop Pro (PSP) is the tool that ITSO uses to capture (and, if necessary, modify) panels 
and windows. Other programs, such as SnagIt, may also be used.

You might want to read 4.8, “Best practices for capturing” on page 61 before proceeding.

4.3.1  Setting up for a capture

Before you capture anything, you need to configure PSP, as follows:

1. Open PSP.

2. Click File → Import → Screen Capture → Setup. 

Figure 4-1   Setting up for a capture

3. Choose a type of capture and set an activation method, as shown in Figure 4-1. There are 
five types of captures:

– Area: This lets you capture any rectangular area on the window.

– Full screen: This option captures the entire window. Typically, an entire window is too 
large to fit on the printed page and still be readable.

– Client area. A subarea of a window; it excludes components such as the menu and 
button bars and a status line.

– Window. The window that is active at the time the capture is made.

– Object. This option lets you capture components of a window such as a button, or a 
menu bar, or some other subarea. Figure 4-1 was captured this way.

4. Select Include Cursor if you want to include the cursor in the capture. We recommend 
that you not select this option unless you really need the cursor to indicate an action. Use 
the FrameMaker graphics palette instead (see 4.3.6, “Annotating your drawings and 
captures” on page 51).

5. Select Multiple Captures if you intend to do a series of captures in succession without 
having to restart the capture process after each one. After you have taken the last image, 
restoring the PSP window terminates the capture process.

Note: The version of PSP used in this chapter is Version 8.10. 
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6. Click OK to save the settings and to start a capture at a later time, or click Capture Now 
and go to step 8.

7. Click File → Import → Screen Capture → Start. Alternatively, press Shift+c.

PSP minimizes and waits for you to do a capture.

You can cancel the capture at any time by restoring the PSP window.

8. After you have set up the window to be captured, use the activation method you defined 
(as per Figure 4-1 on page 46, our method is F11).

What happens next depends on what capture method you selected:

– Area: The cursor changes to a crosshair. Move it to the top left of the area you want to 
capture, click, and release. Now move the mouse to the bottom right corner and click 
again (remember: this is not a click-drag operation). PSP reappears showing the 
captured area.

– Fullscreen: PSP immediately reappears with the entire panel captured in a window.

– Client area: PSP immediately reappears after capturing the client area of the active 
window.

– Window: PSP immediately reappears after capturing the active window.

– Object: PSP puts a border around what it thinks you want to capture. If that is not what 
you want, move the cursor around and PSP puts the box around other possibilities. 
When you see what you want, click the mouse key. PSP reappears with that object 
captured.

4.3.2  Saving the capture

The next step is to save the capture to a file. Use the GIF file format. This format keeps file 
sizes small but limits the number of colors to 256. This is sufficient for most captures. 

1. Click File → Save (or Ctrl+S) to save the capture to a folder.

2. Type in a name that you (and others) can easily recognize later. 

Ask your project leader whether there is a recommended naming convention to use for 
captures. For example, if you are documenting an installation procedure, the captures 
might simply be Installation-01, -02, etc. Starting similar captures with the same set of 
characters means they are grouped in the Explorer view of the directory.

3. Save the file in a subdirectory of your book directory. In the ITSO, we typically store all 
images in the Images subdirectory. Check with your project leader for specifics and 
whether he or she wishes to further subdivide images into chapter-by-chapter directories.

4. Specify GIF as the file format. There are a variety of formats you can save to in PSP, 
including the following:

– GIF: recommended for all captures. Limits images to 256 colors.

Tip: After saving your options (capture method, hot key, and so on), they stay that way 
until you change them. You do not need to reenter the settings window each time. You 
can start the capture process from step 7.

Tip: Save the GIF file in a subfolder named Images. Save all artwork source material 
(Freelance and such) in a subfolder named addmat.
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– TIF: recommended for captures where 256 colors is insufficient (rare). Make sure you 
save it in a compressed format (click Options in the Save dialog box).

– BMP: not recommended because the file size is very large (sometimes 10 times larger 
than GIF).

– PSP: not recommended because it is a proprietary format not readable by any program 
other than Paint Shop Pro.

– JPG: not recommended for captures. JPG is a “lossy” format and does a poor job with 
straight lines. The result: obvious “JPG artifacts” in a poor-quality (and potentially 
unreadable) image. (JPG is good for photos, however.) Figure 4-2 shows what saving a 
capture as JPG does to image quality. 

Figure 4-2   Comparing JPG and GIF formats

5. Click Save.

The image is now saved as a GIF file. 

Typically you will now insert the image into FrameMaker as described in 4.3.3, “Inserting a 
capture into your document” on page 48. 

4.3.3  Inserting a capture into your document

To insert a capture into a FrameMaker document, first insert an anchor frame. Click Toolkit → 
Quick Access Menu and then select Insert Figure NoBox For Graphics.

The result of inserting the anchor frame is both a figure frame and a caption.

Now that you have a frame, the next step is to insert the capture. Follow these steps:

1. Select the frame by clicking anywhere on the border.

2. Click File → Import → File. 

Tip: By default, PSP always reverts back to .PSP as the default file type choice. You 
can configure PSP to remember the last file type selected by clicking File → 
Preferences → General Program Preferences, selecting the Display and 
Caching tab, then checking Re-use last type in file save-as dialog.

The JPG version of the image 
has shadows or artifacts around 
the text. The text is also fuzzy.

The GIF version of the image 
has a clear background with 
crisp text.

Poor Good
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Figure 4-3   The Import dialog box

3. Navigate to the subdirectory where you saved your capture and select the image; see 
Figure 4-3.

4. Now select the import method your project leader wants you to use, either Import By 
Reference or Copy Into Document.

a. Select Import By Reference. The characteristics of this method are:

– Image files are stored in external files (the GIF files) in their original locations. Only a 
pointer is saved in the FrameMaker document. Therefore, the GIFs must be stored in a 
subdirectory of the book file.

– Changes to the GIF file are automatically reflected in the FrameMaker document.

– FrameMaker documents that use Import By Reference are smaller than their Copy Into 
Document counterparts, because the image files are not stored in the FM file.

– When you double-click a graphic that is imported by reference, the default Windows 
application that is associated with that file type (for example, PSP for GIF files) is 
started and the original GIF file can be edited.

b. Select Copy Into Document. The characteristics of this method are:

– Image files are copied into the FrameMaker document. There is no link to the original 
location. 

– To change the image, you must find the source in the Images subfolder, edit the file, 
and repeat the Copy Into Document process.

Note: To associate GIF files with PSP, do this: In PSP, select File → Preferences → 
File Format Associations and check the box for the GIF format.
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– Your project leader might prefer this method because it avoids any possible link 
breakage, which can cause time-consuming rework after residents have returned 
home.

5. Click Import. The window shown in Figure 4-4 appears, prompting you to specify the dpi 
value for the capture. This value determines how big, physically, the capture will be on the 
printed page.

Ask your project leader which dpi value to use in your book. Whichever value you use, be 
consistent and use that same dpi value for every imported capture, if possible.

If your project leader does not have a preference, use 120 dpi.

Figure 4-4   The dpi value determines the size of your capture 

6. Either select the dpi value from one of the radio buttons, or enter the value in the Custom 
dpi field.

7. Click Set. The capture is now in the anchored frame.

4.3.4  Preserving the links

If you send the FM file to someone else, use the ZIP function in the Toolkit to package all the 
referenced GIF files with the FM files. Otherwise, they will not be able to see the captures. 

Important: The size of a capture should reflect the size of the object, that is, a small 
window should look small on the printed page, and a larger window should look larger. 
Do not try to make all captures the same size. Use the dpi setting to determine the 
physical size. Using a consistent dpi setting results in consistent text size in the 
windows, and a consistent overall look to the book.

Note: Because Redbooks are printed at 600 dpi, some purists say that the dpi value 
used here should divide equally into 600. Suitable values, therefore, would be 300 (two 
times), 150 (four times), 120 (five times) and so on. The theory being that at 120 dpi, 
exactly 5 dots are used to print each pixel in the graphic. 

However, to most readers, choosing 120 versus 125 dpi is of little-to-no difference in 
terms of print quality. So this argument can be ignored. 
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A new tool is now available to archive a single chapter. Before doing this, make sure your 
artwork and captures are in subfolders of addmat or Images, respectively. A good method is 
to organize these folders by chapter, that is, addmat\chapter1, Images\chapter2, and so on. 
When you send the ZIP file to your PL, he/she simply unzips it into the book directory, which 
preserves the links.

Click Toolkit → Create 1 chapter ZIP. 

4.3.5  Resizing the image

To adjust your figure, do any or all of the following: 

� If the graphic is of the desired size, select it and click Align Graphic in the Quick Access 
Menu; see 2.2.22, “Align Graphic” on page 25.

� If the capture does not fit into the frame, click the frame to select it, then drag the resize 
handle (a black rectangle on the frame border) down so that it is just below the image. 

� If the capture is too small for good visibility, right-click it, select Object Properties, and set 
a new dpi (a smaller dpi number results in a larger image). Be consistent with the use of 
dpi values for your captures. 

4.3.6  Annotating your drawings and captures

Use FrameMaker’s drawing tools when you want to annotate a capture—that is, point to 
particular fields, buttons, or code, and provide a brief explanation, as in Figure 4-5 on 
page 52.

To get to the Tools palette, click Graphics → Tools or the triangle icon just below the font 
catalog icon in the upper right portion of your FrameMaker panel. You will see the graphics 
menu shown in Figure 4-5 on page 52.

Important: If your artwork or GIF files are in the base addmat or Images directory, there is 
the possibility that files of the same name are overlaid.

Tip: Do not drag the corner of a capture to change its size. While this might be a 
convenient method, it results in inconsistent sizes of your captures. Always resize a 
capture by changing the dpi using Object Properties. And after it is set, keep this value 
consistent. There are occasions when a different dpi (150, for example) is 
necessary—but again, try to maintain consistency.
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Figure 4-5   Tools palette and a few of its key features

Annotations can be particularly effective on captured menus on which the reader is asked to 
perform a number of actions. Figure 4-3 on page 49 can be annotated as shown in 
Figure 4-6.

Figure 4-6   Using annotation instead of following text

4.3.7  Masking images

If you need to hide information on a captured image, such as client or system information, you 
can do so by creating a mask. First set up the image so that you can place text elements on 
top of it, as follows: 

1. In FrameMaker, right-click the image and select Runaround Properties.

2. In the Runaround Properties window, select Don't Run Around and click Set.

Use this to draw lines, such as this one (tip: hold the Shift key down 
as you draw the line).
Use this to draw a rectangle (sharp or rounded corners) around a 
portion of a window. You can make it see-through by setting the fill 
pattern  to None.

Use this to insert a single line of text.
Use this to insert a text frame for a body of text. For another method, 
see 3.3, “Inserting a frame for both text and graphics” on page 36.

Use this to specify the thickness of the line or shape. The current 
value is shown to the right. 
Use the left box to define the end-of-line arrow, then click the right 
box to apply it to the selected line.

Use this to specify the color of an object. The box to its right shows 
the current value.

1. Navigate to the 
subdirectory where you 
saved your capture.

2. Select the image.

3. Select Import By 
Reference.

4. Click Import.
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Now create a text box over the information that you want to hide.

1. Open the Tools palette as explained in 4.3.6, “Annotating your drawings and captures” on 
page 51.

2. Click either the Place a Text Frame icon or the Draw a Text Line (A) icon depending on 
the amount of text you need to add.

– If you choose the Place a Text Frame icon, your mouse pointer changes to show a 
cross-hair. 

i. Click your image to select the area that you want to mask with the text box.
ii. Click Set on the window that opens to accept the default.

– If you choose the Draw a Text Line (A) icon, your mouse pointer changes to a floating 
cursor. Place the cursor on your image where you want to start typing and type your 
text.

3. As you type your text, you might notice that it does not immediately cover the text or area 
on your image that you intended to mask. To correct this, you must set the background of 
the text box.

a. Select the text box that you created. Press Ctrl and then click the text frame to select it. 
Be careful not to also select the image itself.

b. With the text frame selected, on the Tools palette, click the Set Fill Pattern icon (left 
image in Figure 4-7). From the Fill options that are displayed, select the solid white 
option in the center (right image in Figure 4-7). Your text box now turns white. 

Figure 4-7   Setting the fill pattern

Note: If you chose the text box icon from the Tools palette, you can perform the 
following steps immediately after you draw the text box as explained in step 2. This 
makes it easier for you to see the text that you add.

Select the Set Fill Pattern 
icon, and then you see 
the Fill options box where 
you select the center 
white box.
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4. With the text box selected, you can customize it further, for example:

– You can change the font size by highlighting the text and selecting Format → Size → 
9 pt. You might need to specify a smaller size to match the size of similar text in your 
image.

– You can change the white color to another color using the Set Color icon in the Tools 
palette.

– You can fine tune the size and placement of the mask to fit perfectly on your image.

In the example in Figure 4-8, we mistyped the Replicator port and Client port values in the 
window and needed to correct them, but could not run the whole scenario again to recapture 
the window. We created the masks as shown in the text boxes to the right of the values that 
we originally typed.

Figure 4-8   Masking the Replicator and Client port values

After typing the text, we changed the background to solid, resized the font to a size 
comparable to what was in the field, and resized and moved the text boxes over the original 
values to hide them. Figure 4-9 on page 55 shows the result of our changes.
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Figure 4-9   Masking of values completed

4.4  Inline graphics

There might be occasions when you want to show a button or icon or such directly inline with 
the text. 

In Figure 4-5 on page 52 we show a small picture of the Fill Pattern button. Here is how that 
was done:

1. In the QAM, click Insert-Anchored-Boxes. The menu shown in Figure 4-10 appears. 

Figure 4-10   Small anchored boxes 

1. Position your cursor.

2. Select the first choice, Graphic inline at cursor position, in Figure 4-10.

3. Click Ok; you get this: .

4. Insert your icon or button or artwork. You might have to reduce the insert to the 
approximate dimensions of the small frame first.
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You might want to insert a frame for an icon or some appropriate clip art at the beginning of a 
discussion. Do the following:

1. Select the type of frame you want; in this example, “Graphic at paragraph start on left.”

2.Make sure the cursor is positioned in the paragraph where you want to 
have the box inserted. Click Ok.  The result is shown on the left. The 
frame has been made solid in order to show it.

3.You can now resize and reposition the frame as needed.

4.Insert your icon or captured object or artwork. 

This might be an example of an icon highlighting the beginning of a discussion of 
a specific subject.

4.5  Callout (left margin) box

You use callout boxes (sparingly) to draw attention to a graphic or text. In the QAM, click 
Insert Anchored Boxes. In the submenu that appears (Figure 4-10 on page 55), select the 
third option, “Text callout box...” A gray box appears in the left margin. See the example at left.

To change the vertical position of the box so that it 
appears exactly where you want it in relation to the 
corresponding text or graphic, do this:

1. Click the dotted anchor box to select it.

2. Click Special → Anchored Frame. 

3. In the Anchored Frame window, change the offset in 
Distance above Baseline field and click Edit Frame.

4. Repeat these steps until satisfied.

You can also move the box by selecting the outside 
border and dragging it with the mouse.

To make the box larger, do this:

1. Select the outside dotted box and drag the top or bottom border.

2. Press Ctrl and click inside the inner text box to select it. Then drag the top or bottom to the 
desired position.

To make the box smaller, reverse the process:

1. Press Ctrl and click inside the inner text box to select it. Then drag the top or bottom to the 
desired position.

2. Select the outside dotted box and drag the top or bottom border.

4.6  Black panels

If you are dealing with existing black panels that were saved earlier (with PSP), then open 
PSP, click File → Browse and go to your book directory where you keep the image files. PSP 
displays thumbnails of all your captures. Click the desired image and proceed with step 4 on 
page 57. 

WESTERN 
AUSTRALIA

SOUTH 
AUSTRALIA

NORTHERN 
TERRITORY

QUEENSLAND

NEW SOUTH 
WALES

VICTORIA

TASMANIA

Type your text. 
Change the font 
size to 8 point if 
the callout 
contains a lot of 
text.

Figure 4-11   Anchored Frame window
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The DOS panel in Figure 4-12 was captured as described in 4.3, “Using Paint Shop Pro to 
capture panels and windows” on page 46.

Figure 4-12   A DOS panel

As stated earlier, a graphic such as this one is not acceptable.

Captures such as this consume too much toner and can cause printers to jam, leading to 
client dissatisfaction. Consequently, a book will not be published until such graphics are 
fixed. 

Two possible solutions are as follows:

� Reverse the colors of the client area of the graphic.

� Use a text version of the graphic instead.

Reversing the colors
To reverse the client area of the graphic, do the following: 

1. Capture the window using the process described in 4.3, “Using Paint Shop Pro to capture 
panels and windows” on page 46.

2. Save the normal color version of the graphic, so that the project leader has the original in 
case it is needed later.

3. Temporarily convert the graphic back to 16 million colors by clicking Colors → Increase 
Color Depth → 16 million colors. 

4. Using the selection tool, , select the black area of the panel. Tip: You might need to 
zoom in using . 

Note: Before importing the changed image, first delete the existing image in your 
document and select the figure box.

Note: It is not just black that is unacceptable. Our experience is that most solid areas of 
dark colors (for example, dark blue) yield unacceptable results. If you are unsure, show a 
printed version to your local editor or graphics specialist.
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5. Click Colors → Negative Image. The colors of the selected area reverse (for example, 
black <> white), leaving the colors of the area outside the selection unchanged. 

6. Decrease the number of colors back to 256 by clicking Colors → Decrease Color 
Depth → 256 colors → Nearest color → OK. 

7. Save the image to another name (different from the original image, so that both versions 
are kept).

The image can now be imported into FrameMaker; see Figure 4-13.

Figure 4-13   A DOS window with color of client area reversed

4.6.1  Copying and pasting the text

A second method might be more suitable if the panel capture is all text, such as in our 
example. Instead of using a graphic capture, copy the text of the window as text and paste it 
into a Text-Cell-Column-Wide figure element, as shown in Figure 4-14 on page 59.

Tip: Do not simply reverse the entire window, including the title bar 
and window sliders. This results in a strange-looking graphic that 
could be distracting to the reader. 

Take the extra seconds to select the dark area before performing 
the negative image function.
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Figure 4-14   A text-only version of the DOS window

4.7  3270 panels

In most cases, you simply copy the text of the window as text and paste it into a 
Text-Cell-Column-Wide figure element, as shown in Figure 4-14.

If you need to do a graphic capture, as shown in Figure 4-15 on page 60, then inverting the 
colors of a 3270 panel is best done the following way:

1. Click the “Setup display colors” button on the panel (see Figure 4-15 on page 60), or 
select Edit → Preferences → Appearance → Color Mapping.

C:\>dir
 Volume in drive C has no label.
 Volume Serial Number is 743D-4A19

 Directory of C:\

03/03/2003  03:55 PM    <DIR>          ADOBEAPP
02/24/2003  03:13 PM                 0 AUTOEXEC.BAT
02/24/2003  03:13 PM                 0 CONFIG.SYS
02/24/2003  03:22 PM    <DIR>          Documents and Settings
02/26/2003  03:01 PM    <DIR>          ibmtools
02/26/2003  03:01 PM    <DIR>          icons
03/01/2003  01:03 PM    <DIR>          NotesSQL
03/05/2003  01:30 PM    <DIR>          Program Files
03/06/2003  12:05 PM    <DIR>          sdwork
03/01/2003  09:32 AM    <DIR>          temp
03/06/2003  12:36 PM    <DIR>          WINDOWS
               2 File(s)              0 bytes
               9 Dir(s)   5,464,227,840 bytes free

C:\>
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Figure 4-15   A 3270 panel

2. The Color Mapping tool for the 3270 panel shown in Figure 4-16 appears.

Figure 4-16   The Color Mapping tool

3. Change the background color to white.
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4. Change the white text to black.

5. Make any additional changes that you think will contribute to the clarity of the capture. 

6. Click OK and start the capture process.

Your captured panel should look similar to Figure 4-17.

Figure 4-17   The converted 3270 panel

5250 panels
On 5250s, just select the text on the green panel and paste it into the text frame.

4.8  Best practices for capturing

The most important step in taking captures is preparing the window before the capture. 

Here are a few pointers (also see Figure 4-18 on page 62). Discuss these with your project 
leader or your graphics specialist if you are unsure.

� What is the purpose or focus of the window? Are you describing something specific or do 
you just want to show the overall layout of the window? Are the important components of 
the window all grouped in one corner or on one side of the window?

Perhaps a cropped version of the window would be more appropriate. There is no point in 
wasting the printed page on unnecessarily large captures.

Quick cropping lesson: In PSP, click the Crop tool, position the crosshairs in the 
upper left corner of the area you want to keep, drag the box until you have exactly what 
you want, then press Shift+R.
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Figure 4-18   What is the purpose of the window

� Reduce the excess white space by resizing the window before capturing it, as shown in 
Figure 4-19. The graphic then takes up less space on the printed page.

Figure 4-19   Resize the image to remove white space

� All captures should be imported into FrameMaker at a dpi setting that is consistent 
throughout the entire book (see 4.3.3, “Inserting a capture into your document” on 
page 48). However, at that dpi setting, a window might be too large to fit in the frame.

Are the menus and buttons 
important?

If the purpose of this window is to 
show the contents of the C: drive, 
then Task entries are 
unnecessary.

Are the File and Folder Tasks and 
the other hidden views important 
to the reader’s understanding?

Resize this window before 
capturing it to remove the excess 
white space.
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Figure 4-20   The image is too wide for the frame

This would typically be an unacceptable capture. The solutions to this are:

– If it must be this wide, use a page-wide figure box rather than a column-wide one.

– Use a larger dpi value so that the image fits (however, this might make the image too 
small and unreadable).

– Recapture the image so that the window fits within the borders of the figure frame.

� If you are unable to resize a window to fit into a page-wide figure with a readable dpi 
setting, but the entire window is important to the discussion, then possible solutions might 
be as follows:

– Split the image into chunks and display each separately.

– Display a small (unreadable) version of the image so the reader sees the context and 
overall layout of the window, then show a smaller “zoomed-in” section of the window in 
normal readable size, as shown in Figure 4-21 on page 64.

This capture is poor because 
it is too wide to fit in the figure 
frame without shrinking it (and 
potentially making it 
unreadable).
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Figure 4-21   Zooming into a section of a window while still showing the full window

� Use standard operating system colors and themes. There are a few reasons for this:

– The standard colors and themes are what most users expect to see. 

– Using standard colors means that multiple authors can take captures that are 
consistent. This is especially important if the project leader has to take more captures 
after you have gone home.

� Capture all windows in a sequence, even if you do not use them all. 

If you are taking captures to document a process, take captures of all the windows that 
appear, even if you do not believe you will use them all. It is far easier to capture them all 
at that time than to have to set up a solution again just to take one missed capture. 
Unused images are not archived, so the excess disk space is only a short-term problem.

� Capture the complete window even if you plan to use only a cropped version of it.

This is similar to the idea of capturing every window, not just the ones you think you need. 
You might think you only need to show a cropped version of a capture. Your project leader, 
however, might think differently (for example, the cropped capture might have become 
contextually insufficient). So save a full window, then save the file as a copy and crop that 
version.

Note: It is better to use the full window whenever possible. Using a cropped version can 
be confusing to the readers because they might not understand the context of the 
image.
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Chapter 5. Tables

This chapter explains how to create a table and how to adjust it to fit your needs. 

5
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5.1  Starting with the Toolkit

Use the Toolkit to insert a table and a caption: Click Toolkit → Quick Access Menu → Insert 
Table 4x4 (or whatever dimension you chose for your QAM). 

Table 5-1   A 4x4 table

The first row is intended for column headings, leaving three rows for data.

5.2  Resizing as needed

To expand to five data rows, do this:

1. Select the last row by swiping the cursor across it.

2. Click Table → Add Rows or Columns.

3.Make your selections in this menu and click Add.

To remove a column, select the column and press Delete.

Make the selection shown and click Clear.

To retain the column and empty all the cells in it, choose 
Leave Cells Empty.

To resize a column, select it and drag the handles.

For resizing with a specific purpose, such as making a column exactly the same as another, 
or keeping the data on one line (see column 2 in Table 5-2 on page 67), and so on, select the 
column and click Table → Resize Columns.

Note: Do not use the Insert Table function of the Table menu to do this.
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Make your selection on this menu and click Resize.

5.3  Changing the table structure

To clear the horizontal or vertical cell divisions to enter text that spans a number of cells, 
select the desired area and click Table → Straddle.

We now have a table that looks something like Table 5-2.

Table 5-2   Showing the described actions

To reverse this change, select the cleared region and click Table → Unstraddle.

5.4  Creating a page-wide table

If you need a page-wide table, do this:

1. Create a table as in 5.1, “Starting with the Toolkit” on page 66.

2. Click in the caption and change it to CaptionTabPage. This moves the caption and the 
table to the page boundary.

You can now add the desired number of columns, and then resize all or some until you have 
what you need. The table might look like Table 5-3.

Table 5-3   Sample page-wide table

This column was resized.

Center text with the  button.

Column head 1 Column head 2
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Should it become necessary to move the table back to the column boundary, click in the 
caption and select CaptionTabColumn, or, in the QAM, select Paragraph Object Shift 
Right. The table will move with the caption, unless there are too many columns to fit. In that 
case, either remove enough columns or reduce the widths sufficiently.

5.5  Highlighting table elements

You might find it a good idea to highlight a portion of a table to draw the reader’s attention to it. 
For example, the last column might contain the values you recommend based on the data in 
the other columns. Do this:

1. Select the column and click Table → Custom Ruling & Shading.

2.Deselect the Custom Cell Ruling box.

3.Open the Fill menu and select 100%.

4.Open the Color menu and select Grey.

5.Click Apply.

With the Custom Cell Ruling box checked you can change the thickness of the lines around 
selected cells, which is another way of highlighting them.

You might want to remove the first cell of the column header row if it contains no data. Do this:

1. Select the cell and click Table → Custom Ruling and Shading.

2. Select the Custom Cell Ruling box.

3. Choose None for Ruling Style.

4. Deselect Bottom and Right outside edges.

5. Click Apply.

5.5.1  Creating table footnotes

To create a table footnote, click Special → Footnote in the appropriate cell. Then type your 
text in the numbered paragraph that appears below the table.

If you need a second reference to Footnote a, click Insert Xref To Footnote in the QAM and 
follow the instructions.

Your table might now look like Table 5-4 on page 69.
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Table 5-4   Highlighting a column

5.6  Importing tables from Word and Excel

If you want to use a table from a Word or Excel file in your chapter, use the steps explained in 
5.6.1, “Placing the table into FrameMaker” on page 69. Because you are starting the table 
from another source, and not the FrameMaker Toolkit Table template, you must then perform 
the steps explained in 5.6.2, “Formatting the table” on page 69, to format the new table. 
These steps give your imported table the look and feel of the table template from the Toolkit.

5.6.1  Placing the table into FrameMaker

Follow these steps to move a table from Word or WordPro into your FrameMaker file.

1. Highlight the entire table that you want to copy and copy it (press Ctrl+c or select Edit → 
Copy).

2. In FrameMaker, place the cursor in your document where you want to place the table. 

3. To paste the table, select Edit → Paste Special or press Ctrl+Shift+v.

4. In the Paste Special window, select Rich Text Format and click OK.

The table might appear in your document as follows:

Word offers a variety of table formats, and this is, of course, a very simple one. But the 
process of converting it to a book format is similar to the one presented here.

5.6.2  Formatting the table

Now change the properties of the table so that it follows the same style, format, and position 
(look and feel) as the Toolkit Table template. 

Select the table and click Toggle Table To Column Page in the QAM.

This will result in Table 5-5.

Table 5-5   Table from Word converted to a FrameMaker table

We recommend

Footnotea

a. This is a table footnote.

Footnotea

Heading1 Heading2 Heading3

Monday Tuesday Wednesday

January February March

Heading1 Heading2 Heading3

Monday Tuesday Wednesday

January February March
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Now toggle the table again, giving you the column-wide Table 5-6.

Table 5-6   The same table after a second toggle, if appropriate

Applying styles and formatting to the table
Do the following:

1. Highlight the first row, called the header row, and from the Paragraph Catalog, apply the 
CellHead tag. Highlight the remaining rows in the table and, again from the Paragraph 
Catalog, apply the CellBody tag. 

2. Now adjust the widths of the columns in the table to fit the width of the text contained 
within. 

The table might now look like Table 5-7.

Table 5-7   The converted Word table, reformatted

If the table breaks onto the next page, you need to reset the header row so that it carries over 
to that page.

1. Place your cursor in the header row and select Table → Add Rows or Columns.

2. In the Add Rows or Columns window, select Add 1 Row(s) To Heading.

3. A new header row appears at the top of the table. Highlight the text from the original 
header row, then cut and paste your text into the new header row. 

Heading1 Heading2 Heading3

Monday Tuesday Wednesday

January February March

Heading1 Heading2 Heading3

Monday Tuesday Wednesday

January February March
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4. The header row should now appear at the top of the next page. Reset the bottom line of 
the new header row to medium weight as follows:

a. Select the first cell row under the header row.

b. Go to Table → Custom Ruling and Shading, then change the settings as shown in 
Figure 5-1.

Figure 5-1   Setting the bottom line of the header row to Medium
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Chapter 6. Style guidelines

This chapter discusses the ITSO rules for punctuation, capitalization, spelling, highlighting, 
and so forth. 

6
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6.1  A few tips

1. Use American English spelling.

2. Spellcheck every file before giving your work to the editor.

3. Keep it simple. Use short sentences. Use standard fonts and styles. 

4. Use the present tense.

Yes: We show how to...

No: We will show how to...

No: In Chapter 1, we showed how to...

5. Write in the active, not passive, voice.

Yes: Load the program...

No: The program is loaded...

6. Do not use “I”; use “we” and “you”. 

Yes: We recommend that you... 

No: It is recommended that, or I recommend...

7. Do not create your own layout. Resist the urge to be creative. 

8. Do not add extra spaces between paragraphs or force new pages. 

9. Do not hardcode cross-references. 

10.Follow the ITSO highlighting conventions we give you in 6.4, “Highlighting” on page 75.

11.Be consistent throughout, especially with capitalization of names, technical terms, and 
such.

12.Include your product’s version number to avoid confusion. Use Version or V.

13.Avoid general titles such as “Introduction” or “Overview,” without further information. 
Include at least a concept or product name.

14.Avoid a section-by-section listing in the chapter introduction. Write a summary.

15.Use serial commas, that is, use a comma before the “and” or “or” that precedes the last 
item of a series of items.

6.2  Headings and captions

The IBM and ITSO style for headings and captions—figure, table, and example—is sentence 
style. That is, use an uppercase letter only in the first word in the heading or caption and on 
any official product names that appear in them. 

Do not put any punctuation at the end of a heading or caption. 

Do not stack headings, that is, do not put one heading under another without some text 
separating them.  
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6.3  Lists

Write a lead-in sentence for every list, ending it with a colon, like this:

� Capitalize the first word of each item in the list. 

� Put a period at the end of each item if any item in the list is a complete sentence.

� If the lead-in wording is on one page and the list starts on the next page, put the cursor 
into the lead-in sentence and, in the QAM, click Keep with next—or let your editor fix it. 
Do not force a Page Break.

6.4  Highlighting

Here are the ITSO standards for highlighting:

� Bold - use the Bold character tag or Ctrl+b.

– Use for selections made from a window or menu.

– Use the following format to tell users which items to select:

Click File → Tools → User preferences.

� Emphasis - use the Emphasis character tag.

– Use for emphasizing a word or words (for example, not or as required).

– Use when a new term is introduced in the text (optional).

� Monospace - use the Example character tag for in-line text, or the BodyExample paragraph 
tag for a separate paragraph.

– Use it for file names and directory names.

– Use it to show what a user would see, or type, on the terminal. Example: The system 
will respond with the error message The inetd daemon has died. 

– Use it for URLs. These should be on a separate line so that the period at the end of the 
sentence is not mistaken for an element of the web address. Example: The following 
URL gets you to the IBM Redbooks site (using BodyExample2):

http://www.redbooks.ibm.com/

To make the URL “hot,” select the URL (make sure no trailing blanks are included) and 
click Toolkit → Make URL Hot.

� Commands - use the Commands character tag.

Use for the names of lowercase commands (for example, the copy command).

When a command has parameters, it is a good idea to put it on a separate line, in which 
case it is better not to bold it. BodyExample is then the tag to use. The purpose of bolding 
is to make a word stand out from normal text. Being on a separate line, in nonproportional 
font, accomplishes this goal as well.

The traditional all-cap commands, such as VM or TSO or RACF commands, do not get 
any highlighting.

� Citation - use the Citation character tag for the title of books. See examples in 6.5, 
“References to other publications” on page 76.

� Italic - use this character style (Ctrl+i) for variable values within a command specification, 
such as:

copy ccc.mmm.nnn
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� No highlighting is needed for keys, storage areas, tasks, trademarks, utilities, wizards, and 
the names of fields. 

� Field names, panel or window titles, menu names, and key names should be capitalized 
as they appear in the window or on the keyboard. 

See also 1.4, “The character catalog” on page 6.

Table 6-1 presents an overview of the highlighting rules discussed in this section.

Table 6-1   Highlighting conventions in Redbooks

6.5  References to other publications

All references in the text must be listed in the bibliography (bibl.fm), as follows: 

� Redbooks and IBM manuals

Title, order number

Example: FrameMaker and Writing Guidelines for Residents, SG24-xxxx

Do not include dash levels on these books (for example, -00, -01, -02).

Always use the full title; do not shorten it. 

Tip: Some names are long and use sentence-style capitalization, making it difficult to 
know where they end and where the text continues. Use quotation marks to highlight 
such names, as in the sentence: The field “Create databases and templates” shows...

Use for:

Character or paragraph tags

Bold Italic Emphasis Commands Example BodyExample Citation None

Lowercase commands 

All-cap commands
(VM & MVS)



Window or menu choices 

Variables in commands 

Emphasis 

New terms on first use 

URLs & message text 

Message text, in-line 

Book titles 

Window names 

Field names 

File names 

Directory names 

Key names 
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� Non-IBM publications

Author, Title, Publisher, Year, ISBN - when listing in the bibl.fm

Example: Hargis, et al., Developing Quality Technical Information: A Handbook for Writers 
and Editors, Prentice Hall, 1998, ISBN 0137903200

Title, by Author - when referencing in the body

Title, by Author et al - when the book has multiple authors

� Publications on the web

Title, found at: 

http://www.xxxxxxxx.yyy/123/456.html

Be sure to use the fully qualified address that includes http://www. 
� APARs

Titles are in plain text and require sentence-style capitalization.

APARs are announcements about product fixes—do not add them to bibl.fm, although 
they should be included in the index.

� Articles 

Titles are in quotation marks; for example, “IBM, Compaq solidarity” by Sonia R. Lelii in 
eWeek, July 10, 2000

� Chapters within a book

Chapter titles are in quotation marks, for example:

See Chapter 6, "Application development guidelines", in User-to-Online Buying Pattern 
using WebSphere Commerce Suite, SG24-6156.

For non-IBM publications: See Chapter 6, "Inserting Graphics", in FrameMaker 5.5.6 
for Dummies, by Sarah O'Keefe et al.

� Knowledge Base articles

Titles are in quotation marks.

� OSS notes

Titles use the Citation tag.

� Redpapers and white papers

Titles use the Citation tag.

� Request for Comments

Titles are in plain text with appropriate capitalization.

� Only references beginning with SG or GG are to be listed in the IBM Redbooks section of 
bibl.fm; all others are to be listed in the “Other resources” section. The only exception to 
this is SC09-2180.

Note: For consistency and accuracy, create variables for all book titles. Use the last four 
numbers for the names instead of inventing short titles whose meaning will not be 
obvious. And make sure the variables you create are imported into all chapters of your 
book.

When creating a variable, the following syntax creates the desired format:

<Citation>TCP/IP in a Sysplex,<default font> SG24-5235
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When titles are changed in the bibliography, be sure to change them in the text, too.

6.6  Abbreviations

Use the glossary to list abbreviations and acronyms you use in the document.

Spell out the meanings of all-caps abbreviations on the first use in each chapter. Example: 
Advanced Peer-to-Peer Networking (APPN).

Note that k means times 1000 (32 k means 32,000), whereas K means times 1024 (32 K 
means 32x1024). K also means Kelvin (32 K means 32 Kelvin). When K is used, it must be 
defined in the list of abbreviations or in the glossary.

Use MB (not megs and not mb) for megabytes. Use Mb for megabits.

Use KB, not Kbytes, for kilobytes. Use Kb for kilobits. Use kbps (note lowercase k) for 
transmission rate. 

6.7  Numbers

Write plurals of numbers like this: ones, 6s, 3174s, 1990s. 

Spell out numbers zero through nine. 

Spell out the ordinals first through ninth (not 1st, 2nd, 3rd) except when in a series (the 3rd, 
6th, 9th and 12th passes).    

The words billion and trillion do not mean the same in all countries. To avoid confusion, 
always express these amounts as numerals.

Use numerals, not words, for:

Units of measurement (a byte contains 8 bits)    

Particular items, units, or values (tape unit 6, return code 8) 

Do not begin a sentence with a numeral; write the number out instead. For example: Eight bits 
constitute a byte. 

Measurements should be written first in metric units and then in English units in parentheses. 
For example: 76.2 mm (3 in.). 

Put a space between the number and abbreviations such as mm, in, Mbps (for example, 
64 Mbps), MB, KB, kbps, MHz, and Mb (for example, 16 MB, 64 KB). 

6.8  Spelling

Use American English spelling. For example, the correct spelling is: customization, 
initialization, color, while, expiration, analog, and center. 

Plurals of all caps should be DCBs and PCs (not PC's).

Do not call your book a “manual.” It is a publication or a book.
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Capitalize the term Redbooks (plural). Do not use the term ITSO Redbooks; use IBM 
Redbooks.

To check any spelling, consult the Dictionary of Computing (formerly called the Software 
Glossary) at:

http://www.networking.ibm.com/nsg/nsgmain.htm 

Or use Webster's New Collegiate Dictionary. Be aware that spell checkers are unreliable.

The IBM Style Guide’s preferred spelling of hundreds of terms found in technical publications 
is at:

http://wwwidd.raleigh.ibm.com/ralidd/terminfo/word_spe.htm 

Acronyms
Consult the following:

IBM Multilingual Terminology at:

http://w3-117.ibm.com/standards/terminology/cgi-bin/lookup.pl?user_group=corpor
ate

Also:

http://www.whatis.com 
http://www.acronyms.com

Google is also an excellent source.

6.9  Copyright issues

You must obtain written consent and permission from the owner of the copyright of any 
copyrighted publication outside of IBM, including any information used from outside IBM 
(books, WWW, magazines, white papers, and so forth), and you must properly cite such 
material. 

Derivative work (that is, reworded or reorganized from another publication or from the web) 
does require attribution and permission forms. 

Before republishing material from any source outside of IBM (whether or not the source bears 
a copyright notice or other restrictive legend), you must confer with your manager to decide 
whether republishing the material is necessary. 

Copyright owners generally specify how they want the copyright acknowledgment worded and 
where it should be located.

The permission must constitute worldwide permission to copy, print, and translate the 
material in the proposed publication and in future revisions and editions of the publication. If 

Important: Copyright laws apply if importing from the web! When in doubt, consult your 
project leader.

Important: Unless otherwise instructed, put the attribution into a footnote.
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there are any plans to modify or adapt the copied material, the written permission must 
include express authorization to modify and adapt the material. 

If you reproduce software in a publication (for example, have window captures of non-IBM 
products), make sure that you have an appropriate copyright license or that the software is 
truly in the public domain. 

Obtain signed model release forms, indicating their permission, before publishing anyone's 
name or photo on the Internet. 

When you have received permission, use the following format for the citation:

Source: Reprinted, by permission of the publisher, from Title, Publisher (not author), year, 
pages 
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Chapter 7. Writing guidelines from class

Figure 7-1   Writing an IBM Redbooks publication, or a Redpaper, or anything else done with FM

7

International Technical Support Organization

Writing for the ITSO
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Figure 7-2   Basic advice

Figure 7-3   More basic advice, plus a few corporate rules

Writing guidelines

Use American English spelling.

Write in short, simple sentences.
No: What this script does is to create the directories.

Yes: This script creates the directories.

Use the present tense.
No: The daemon will be polling the network.

Yes: The daemon polls the network.

Use active voice when possible.
Passive: The Name window is used to enter your name.

Active: Use the Name window to enter your name.

Use examples, lists, tables, scenarios.

Use an informal style
Instead of "The user should...", say "You should..."

Writing guidelines

Use "we" (not IBM) when you mean the book's authors.

Use gender-neutral terms, not his/her (use plurals).

Spell out meanings of abbreviations on first use.
  The network address block (NAB)...

Introduce (and xref) every figure, table, and list before it appears.
   The following list shows...
   Table 5 lists...

Avoid contractions - don't, can't, isn't, won't, and so on

etc. -> and so on; i.e. -> that is

Some new rules:
CPU -> processor
customer -> client
Web -> web; Web site -> website
end user -> user
screen -> panel, window
recommend -> suggest, advise
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Figure 7-4   More rules

Figure 7-5   Some English advice

 Writing guidelines

Use sentence style capitalization in headings and captions.

Do not create your own layout. Resist the urge to be creative.

Avoid a section-by-section listing in the chapter introduction. 
Write a summary.

Be consistent throughout, especially with capitalization of names, 
technical terms, and such.

Avoid slash marks whenever possible; if necessary, leave no 
space around them (install/migrate).

Use double quotes around text ("text", not 'text').

Put text after every heading.

Headings and captions should be unique.

Use the highlighting rules shown in the Writing Guidelines, 6.4.

Use serial commas (apples, oranges, and kumquats).

Some writing tips

Filler words (do they add anything?)
Main, major, basic, all, different, actual

Plurals
PTFs - not PTF's.
1990s - not 1990's.
Nodes - not node(s); a single instance is included in many.

Verbs and nouns
Before you set up your setup

A or an?
A sensitive guy, an unusual thing - but...
An SP expert, a useful asset
An hour and a half 
(The following sound is what matters.)  

Hyphens - the fewer, the better
Reboot, multiprocessor, prearrange, online
But: user-written code, RACF-based security

Humor and colloquialisms 
Often impossible to translate (the daemon bit the dust, kicked 
the bucket, bought the farm)
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Figure 7-6   Important rules, and two useful sites

Figure 7-7   Yes, editors do all that

Make sure that fictitious names in your examples are not real.

Copyright laws apply if importing from the web -- consult your 
project leader! 

Put attributions into a footnote.

http://www.yourdictionary.com (800+ dictionaries in 200+ 
languages)

Online tutorials

http://w3.itso.ibm.com/itsoapps/redbooks.nsf/pages/w3fmlessons?Open

http://www.redbooks.ibm.com/redbooks.nsf/pages/fmlessons?Open

Don't use the wheel on your mouse, or the touchpad on your laptop 
-- FrameMaker might punish you by crashing.

 Miscellaneous

On editing

We check the following:
 Corporate guidelines

 ITSO guidelines

 Spelling and word use

 Sentence structure and punctuation

 Complexity

 Organization and logic

Bring your first 3 to 5 pages to an editor for early 
feedback.
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Figure 7-8   The beautiful language

ITSO  Poughkeepsie, New York                       1998

The beauty of English

Homographs are words of like spelling but with more than one meaning. 
A homograph that is also pronounced differently is a heteronym.

The bandage was wound around the wound.

The farm was used to produce produce.

The dump was so full that it had to refuse more refuse.

We must polish the Polish furniture.

He could lead if he would get the lead out.

The soldier decided to desert his dessert in the desert.

Since there is no time like the present, he thought it was time to 
present the present.

A bass was painted on the head of the bass drum.

When shot at, the dove dove into the bushes.

I did not object to the object.

The insurance was invalid for the invalid.

There was a row among the oarsmen about how to row.

They were too close to the door to close it
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